1
$\begingroup$

I am trying to run the LIL statistical testing tool that can be found here http://webpages.uncc.edu/yonwang/liltest/

When I execute the jar with:

java -jar LILtest.jar -s -p -a -b binaryfile.dat -l 0 

The program says it has written data to lilCurve.pdf and lilSnap.pdf but no such files exist anywhere on my computer instead there is a file called LILSnap that contains at most one floating point number. I have R installed and I have tried running the tests with the -r flag to no avail. My current theory is that the program was created on top of an older version of R which is causing problems. Additionally, there are certain times where I run the software and get this as output (Infinity and NaN are unexpected and are usually outputted as floating point numbers):

It is 1070MB long. I divided this file
into 2140 sequences (each sequence is 512KB) and
carried out LIL testing on them.

You have requested to generate the LIL curve pdf file. The resulting
LIL curve file could be found in: lilCurve.pdf

You have requested to carry out the snapShot testing. I generated
the snapShot curve in the file: lilSnap.pdf. The statistical
distances are as follows (if the actual value is smaller than the expected
value, then your sequence passed the LIL test):
Total Variation:
                Infinity(expected)
                0.0 (actual)
Hellinger distance:
                Infinity(expected)
                NaN (actual)
root-mean-square deviation:
                Infinity(expected)
                NaN (actual)

This test is referenced in a number of relevant papers and it's a bit disappointing that it does not work out of the box.

If anybody knows of any secret debugging tips I would appreciate your input.

EDIT 1: I am trying to run the program with the different major versions of R, it looks like the program was written in 2015 and R 3.x.x was released in 2016/7 ish.

$\endgroup$

closed as off-topic by yyyyyyy, otus, fgrieu, poncho, kodlu Mar 13 '17 at 20:52

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Programming questions are off-topic even if you are writing or debugging cryptographic code. Unless your question is specifically about how the cryptographic algorithm or protocol works, you should look into asking on Stack Overflow instead." – yyyyyyy, otus, fgrieu, poncho, kodlu
If this question can be reworded to fit the rules in the help center, please edit the question.